README.txt 250301 no Didplay installed, CLI only, instead GUI is installed SD written by imager, IMG: raspios-bookworm-arm64-lite 2024 - lang=de, Time=Berlin, keyb generic 5 keyPC, country DE, name=gerd, PC name= raspi (made backup) - eth0 changed: 192.168.178.127 (nmtui) - installed mc, aptitude i01 - apt update, upgrade (139 upgraded) i02 - installed sundtek drv - installed samba - samba: smbpasswd -a gerd; dirs adapted in smb.conf; nmbd + smbd active - installed vdr, vdradmin-am (By default VDR is configured to use /var/lib/video to store recordings. You can either create this directory (not done) or change this behavior later by modifying the config file /etc/vdr/conf.d/00-vdr.conf) (if: systemctl status vdr --> ERROR: invalid primary device number: 1 sundtek drv must be installed first ! , corrected by purging vdr, vdr-admin-am and installing old version of sundtek drv, normal version of vdr, vdr-admin-am ) - /var/lib/vdr/setup.conf: changed: MaxVideoFileSize = 20000 (2000 = default) (shut down vdr before changing) - vdr probs: command needs more time / delay do: supplement commandline in /boot/cmdline.txt by rootdelay=15 net.ifnames=0 not done ! or: (see: https://www.vdr-portal.de/forum/thread/133724-error-invalid-primary-device-number-1/) sudo vi /etc/systemd/system/vdr.service.d/delay.conf or /etc/systemd/system/multi-user.target.wants/vdr.service -> /lib/systemd/system/vdr.service supplement code in either file above: [Service] ExecStartPre=/bin/sleep 15 done ! - update - /etc/defaults/vdradmin-am enable=1 i - USB-devices are automatically mounted - raspi-config: splash screen disabled, start in command line mode, login automatically, default browser firefox (start in comandline-mode: systemctl set-default multi-user start in graphical-mode: systemctl set-default graphical) ***** 250302 - copied files : mount-Verb-DATA, mount-Verb-DATA-XFS, mount-WD-DATA, pishutdown.py, restart-vdr.sh, show-owner-of-video-00.sh to /usr/local/bin (customized paths/names, "sleep" removed) - copied file pishutdown.service to /etc/systemd/system; activated by: systemctl start pishutdown chmod 644 /etc/systemd/system/pishutdown.service commented out: #StandardOutput=syslog, #StandardError=syslog (err: pishutdown.service halt doesn't work ! does work ! ???? to test ) - /etc/defaults/vdradmin-am enable=1, ok ***** 250305 - supplementd /etc/vdr/conf.d/00-vdr.conf: [vdr] --video=/media/Verb-DATA-XFS - /etc/rc.local: invokes /usr/local/bin/mount-Verb-DATA-XFS etc. to mount partitions for video-record-files, removed "wait 15" - file-manager customized: don't mount mountable volume auto on prg-startup don't mount removable media auto when they are inserted ------------------------------------------- https://forums.gentoo.org/viewtopic-t-449220-start-0.html 01.04.2006 — If you want users to be able to mount/umount it you can add the keyword "user" to your fstab (where you currently have default, change it to defaults,user)